Copyright © 2004, Compiler Resources, Inc.
XP, Sasser, et. al.

Yacc++ and the Language Objects Library

XP Compatibility

Some customers have told us that "old" versions of yxx have stopped working with XP or Win2K with the Sasser patch. (Revisions 2.1 and prior seem to all have the problem.) Our belief it is an incompatibility in the OS libraries that causes this problem.

Recent versions of yxx have been confirmed not to have these problems. We have not had any reports of the problem with Rev 2.4.

The only known solution is to upgrade to a recent version. There are no known work-arounds.

Note, for customers that have particularly difficult problems upgarding to the new releases, we can make "special" versions of older revisions of yxx compiled to run under XP. However, these versions are one-of-a-kind and are not are normally supported code and are intended to mitigate migration problems only. We are working on a way of having the newest yxx generate code compatible with the older versions of the library. Library compatibility is not normally an issue, except for customers who are still using the 1.x format of the libraries or have used the sources to the libraries to access the internal interfaces. This will be released later this year.

We are sorry for any inconvenience this may cause.

Last updated on 4 July 2004.
To send email to Compiler Resources, Inc.

Return to Yacc++ Home Page